Updated
Looks like everything is going back to normal. Please contact me on twitter: @K_4Unl if you find anything odd.
Posted
22 Oct at 10:01pm CEST.
Completed
Maintenance completed
Posted
22 Oct at 10:00pm CEST.
Updated
All data is copied, but we're having some small problems with the new drive.
Hope to be up soon. Sorry for the inconvenience.
Posted
22 Oct at 07:45pm CEST.
Started
Due to the filled up drives, we're again moving to a bigger drive.
Posted
22 Oct at 02:45pm CEST.
Maintenance